US Prod and EU Prod - Formula Executions outage

Incident Report for Cloud Elements

Resolved

This incident has been resolved.
Posted Aug 25, 2026 - 10:34 MDT

Monitoring

A fix has been implemented and we are monitoring the platform. Formulas are healthy now.
Posted Aug 25, 2026 - 06:57 MDT

Investigating

Formulas Execution is facing an outage in U.S. and EU production. Our Engineering teams are working on it and will provide updates at regular intervals.
Posted Aug 25, 2026 - 03:14 MDT
This incident affected: US Production (Formulas) and EU Production (Formulas).