Formulas Degraded across US and EU Production environments

Incident Report for Cloud Elements

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 22:36 MDT

Investigating

We’re presently encountering a problem with formulas in our US and EU Production environments. Our team is actively investigating and will ensure to provide updates as they become available.
Posted Oct 20, 2025 - 06:58 MDT
This incident affected: US Production (Formulas) and EU Production (Formulas).