EU Production: Database Maintenance
Scheduled for Sep 27, 16:00 - 18:00 MDT
Update
We will be undergoing scheduled maintenance during this time.
Posted 11 days ago. Sep 09, 2019 - 16:43 MDT
Scheduled
We will be performing database maintenance in the EU Production environment. Customers in this environment may experience a brief disruption of service.
Posted 11 days ago. Sep 09, 2019 - 16:42 MDT
This scheduled maintenance affects: EU Production.