US Production - degraded performance for some formula executions
Incident Report for Cloud Elements
Resolved
This incident has been resolved.
Posted Jul 03, 2020 - 19:55 MDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jul 03, 2020 - 18:46 MDT
Identified
The cause of the issue has been identified and we are working on implementing a fix.
Posted Jul 03, 2020 - 16:56 MDT
Investigating
We are currently experiencing degraded performance for some formula executions with our US Production Environment and are actively working on restoring the environment.
Posted Jul 03, 2020 - 13:32 MDT
This incident affected: US Production (Formulas).