Formula Performance Degradation
Incident Report for Cloud Elements
Resolved
The performance degradation has now been resolved and formula processing time is returning to normal.
Posted 4 months ago. Apr 26, 2018 - 11:52 MDT
Investigating
We are currently experiencing some slight performance degradation on our formula processing times for some accounts and are actively working to resolve this issue.
Posted 4 months ago. Apr 26, 2018 - 10:52 MDT