EU Environment High Latency
Incident Report for Cloud Elements
Resolved
This incident has been resolved.
Posted 23 days ago. Sep 30, 2017 - 13:06 MDT
Investigating
The EU environment is currently experiencing high latency, and Engineering is investigating.
Posted 23 days ago. Sep 30, 2017 - 12:33 MDT