Degraded Performance in US Production
Incident Report for Cloud Elements
Resolved
This incident is now resolved and formula performance is restored.
Posted about 1 month ago. Mar 17, 2018 - 23:10 MDT
Update
We continue to show a trending decline in formula step execution delays, and will monitor until this incident can be marked as Resolved.
Posted about 1 month ago. Mar 17, 2018 - 19:38 MDT
Monitoring
Production queue processing is returning to normal, and additional load management is under review.
Posted about 1 month ago. Mar 17, 2018 - 01:04 MDT
Investigating
We are currently experiencing heavy load: all systems are operating within specifications, but you may experience some minor slow downs.
Posted about 1 month ago. Mar 16, 2018 - 17:20 MDT