Formula Execution Delay
Incident Report for Cloud Elements
Resolved
Formula executions times are back to normal.
Posted 3 months ago. Jul 28, 2017 - 15:11 MDT
Investigating
Users may be experiencing delays in formula executions. Our engineers are actively investigating the issue.
Posted 3 months ago. Jul 28, 2017 - 13:49 MDT