Email Delivery Delayed in Production
Incident Report for Cloud Elements
Resolved
This incident has been resolved.
Posted 2 months ago. Oct 09, 2017 - 10:00 MDT
Identified
We are working on a resolution to the email delivery delays. No other services are currently impacted.
Posted 2 months ago. Oct 09, 2017 - 08:16 MDT
Investigating
There is currently a delay in email delivery in our production environment. The team is investigating.
Posted 2 months ago. Oct 08, 2017 - 14:23 MDT